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Getting Started Guide  

IAR KickStart Kit™ for Fujitsu MB9BF516R 

This guide briefly describes how to get started using IAR Embedded 

Workbench® for ARM with IAR J-Link OB (on-board) debug interface to run an 

example application on the MB9BF516R-SK target system.  

For more detailed information, see the IAR Embedded Workbench IDE User 

Guide and the C-SPY Debugging Guide, which are available from the Help menu 

in the IAR Embedded Workbench IDE and IAR Information Center. 

Features of the MB9BF516R-SK evaluation board 

 MB9BF516R ARM 32-bit Cortex-M3 device 

 J-Link-OB (J-Link for ARM is mounted on the evaluation board controlled 

via USB) 

 Standard 20-pin JTAG connector  

 Trace connector 

 3 choices of power supply: JTAG pin 19, Power jack, USB (On-board 

debugger) 

 Power jack 

 USB driver and connector 

(Host, Device) 

 Reset button 

 User button 

 Power LED 

 User LED 

 Dimensions: 140 x 65 mm 

 RoHS compliant 
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Install IAR Embedded Workbench for ARM 

The installation DVD contains all the software and documentation you need to start building and 

running embedded applications on the MB9BF516R-SK evaluation board. We recommend that you 

follow the installation instructions on the DVD and use the default directories for installation. 

1 Insert the installation DVD. The installation program will start automatically. 

2 First choose which board you are working with, and then move on to the CHOOSE SOFTWARE 

page. 

3 Select the IAR Embedded Workbench for ARM installation of your choice. We recommend the 

Kickstart edition which has no time limit. 

 

Figure 1 - Choose software 

4 You will be directed to an online Product Registration page to get your license number and key, 

which will be delivered to you via e-mail within a few minutes. After this you will be able to install 

the software. Note that it may take several minutes for the installation files to unpack. 

Install the J-Link USB driver 

Before you can use the J-Link OB over the USB port, the J-Link USB driver must be installed. 

1 Connect your computer and the J-Link-OB(USB3) using the USB cable. The Power LED on the 

evaluation board should be lit. 

2 If this is the first time that you are using the J-Link, Windows will start the Install wizard. Choose 

Install from a specific location. If the installation wizard does not start automatically, see note 

below. 

3 When asked to locate the USB drivers, click the browse button and navigate to the \IAR 

Systems\Embedded Workbench 6.x Kickstart\arm\drivers\JLink\x86 or x64 

directory, depending on your computer system. 

4 Click Finish. The J-Link USB driver is now installed.   

Note: If the installation wizard does not start automatically, or you get a message that the driver has 

not been installed properly, please navigate to \arm\drivers\Jlink\ and start the InstDrivers 

application. This will install the J-Link USB driver and the LED should stay lit steadily. 
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Set up the evaluation board  

After you have installed the software and the J-Link USB drivers, you need set the jumpers, see 

Table-2. The MB9BF516R-SK evaluation board can be powered from four different sources. You 

can select the power source by JP1. 

- Power jack. Use an external power supply to feed 5V power   to the evaluation board. 

- JTAG connector. Some debug probes, like IAR J-Link, supply 5V through pin 19.  

- USB connector for on-board debugger (J-Link OB).  

Run example projects 

To take full advantage of the examples, you must have some working knowledge of IAR Embedded 

Workbench IDE. For a quick introduction, see the GETTING STARTED and the TUTORIALS in 

the IAR Information Center for ARM, see Figure-2. 

1 From the Start menu, start IAR Embedded Workbench IDE by choosing All Programs>IAR 

Systems>IAR Embedded Workbench for ARM 6.x Kickstart>IAR Embedded Workbench. You 

will get straight into the IAR Information Center for ARM.  

2 Click EXAMPLE PROJECTS. 

 

Figure 2 - IAR Information Center for ARM 

3 Select Fujitsu>MB9BF51X> IAR MB9BF516R-SK evaluation board.  

4 Open an example project; for example, Blinking LED (click the   icon). 

5 Choose a destination folder to save a copy of this project for testing, so that the original project will 

not be updated for any changes you made during testing. 

6 Follow the instructions in the Example description to configure the board, and choose your build 

configuration, for example RAM Debug. 
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Figure 3 - Example description and Build configuration 

7 Choose Project>Make or click the  button on the toolbar. The project should compile with no 

errors or warnings.  

8 To download your program, choose Project>Download and Debug or click the   button.  

9 The file main.c is now open in the editor window. Choose Debug>Go or click the  button to 

start the application.  

10 To stop C-SPY, choose Debug>Break or click the  button. 

11 To exit C-SPY, choose Debug>Stop Debugging or click the  button. 

12 Now you can try other example projects included, just click Help>Information Center to bring up 

the IAR Information Center again.  
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MB9BF516R-SK evaluation board overview 

 

 

 

 

Figure 4 - MB9BF516R-SK board layout 

 

 

Connector description 

Connector PCB Description 

JTAG JTAG JTAG connector 

TRACE TRACE TRACE connector 

USB1 USB Device USB Device connector 

USB2 USB HOST USB HOST connector 

USB3 USB USB connector for on-board debugger 

J1 J1 Pin header (MCU external pin) 

J2 J2 Pin header (MCU external pin) 

J3 J3 Power Supply 5V DC 

Table 1 - Connector description 

Switches description 

Switches Description 

DSW1 

1: MD0 of MB9BF516R  SW-ON: L, SW-OFF: H 

2: MD1 of MB9BF516R  SW-ON: L, SW-OFF: H 

3: P21 of MB9BF516R  SW-ON: L, SW-OFF: H 

4: P22 of MB9BF516R  SW-ON: L, SW-OFF: H 

USB Select Host / Device 

RESET(SW1) Reset button 

USER(SW2) User button 

Table 2 - Switches description 

  

JTAG connector Trace connector 

Pin header 

User LED 

USB for J-LINK OB  Power Supply 

DIP Switch 

User button 

Reset button 

USB (Device) 

USB (HOST) Pin header 

USB Select 

HOST/Device 
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Jumper descriptions 

 

 

Figure 5 - The MB9BF516R-SK evaluation board 

 

Jumper description 

Jumper PCB Description 

 

JP1 

 

OB 

JTAG 

JACK 

USB 5V power supply 

 JTAG 5V power supply (pin 19) 

Power jack 5V power supply 

JP2 
 MCUVCC 3.3V/5V 

1-2: +3.3V 

2-3: +5V 

JP3  
Enabel Power supply for MCU 

ON (close) / OFF (open) 

JP4 
GPIO 

USB 

1-2: use P81/UDP0 and P80/UDM0 pin as  GPIO (P81, P80) 

2-3: use P81/UDP0 and P80/UDM0 pin as USB (UDP0, UDM0) 

JP5 JTAG SEL 
Select ICE (debugger) 

External JTAG ICE (close) / On-board debugger (open) 

JP7  Connect P21 of MB9BF516R to DIP-SW (DSW1-3). 

JP8  Connect P22 of MB9BF516R to DIP-SW (DSW1-4). 

Table 3 - Jumper description 

 

  

JP3 JP7 

JP8 

JP2 JP1 

JP4 JP5 
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External connectors description 

JTAG 

The JTAG connector allows the software debugger to 

communicate via a JTAG (Joint Test Action Group) 

port directly with the core. Instructions can be inserted 

and executed by the core thus allowing MB9BF516R 

memory to be programmed with code and executed 

step by step by the host software. For more details, 

refer to the IEEE Standard 1149.1 - 1990 Standard Test 

Access Port and Boundary Scan Architecture and 

MB9BF516R datasheets and its user manual. 

Pin # Signal name Signal type Description 

1 VTreF  Target reference voltage – Connected to +3.3V/+5V. 

2 VCC  Power supply – Computex ICE provide power through this 

pin 

3 nTRST Input JTAG reset – The TRST pin can be used to reset the test logic 

within the Embedded ICE logic 

4 NC   

5 TDI Input Test Data In – This is the serial data input for the shift 

register. 

6 NC   

7 TMS Input Test Mode Select – The TMS pin selects the next state in the 

TAP state machine. 

8 NC   

9 TCK Input Test Clock – This allows shifting of the data input, on the 

TMS and TDI pins. It is a positive edge triggered clock with 

the TMS and TCK signals that define the internal state of the 

device. 

10 GND   

11 RTCK  Return test clock signal – Some targets must synchronize the 

JTAG inputs to internal clocks. To assist in meeting this 

requirement, you can use a returned, and retimed, TCK to 

dynamically control the TCK rate. J-Link supports adaptive 

clocking, which waits for TCK changes to be echoed correctly 

before making further changes. Connect to RTCK if available, 

otherwise to GND 

12 GND   

13 TDO Output Test Data Output – This is the serial data output from the shift 

register. Data is shifted out of the device on the negative edge 

of the TCK signal 

14 GND   

15 nRST  Target CPU reset signal. Typically connected to the RESET 

pin of the target CPU, which is typically called nRST, 

nRESET or RESET. 

16 GND   

17 NC   

18 GND   

19 VCC  Power supply - J-Link or some other ICE provide power 

through this pin. 

20 GND   

Table 4 - JTAG signals and descriptions 
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Trace connector 

Pin # Signal name Signal type Description 

1 VTreF Output Target reference voltage - Connected to 

+3.3V/+5V. 

2 SWDIO/TMS I/O / Input Serial wire date input / output / JTAG mode set - 

Connected to SWDIO/TMS of MB9BF516R. 

4 SWCLK/TCK Input Serial wire clock / JTAG clock - Connected to 

SWCLK/TCK of MB9BF516R. 

6 SWO/TDO Output Serial Wire Output trace port  / Test data out - 

Connected to SWO/TDO of MB9BF516R 

8 TDI Input JTAG data input - Connected to TDI of 

MB9BF516R. 

10 nRESET Input JTAG reset - Connected to RESET of 

MB9BF516R. 

12 TRACECLK Output Trace  clock - Connected to TRACECLK of 

MB9BF516R 

14 TRACEDATA[0] Output Trace data pin 0 - Connected to TRACE0 of 

MB9BF516R 

16 TRACEDATA[1] Output Trace data pin 1 - Connected to TRACE0 of 

MB9BF516R 

18 TRACEDATA[2] Output Trace data pin 2 - Connected to TRACE0 of 

MB9BF516R 

20 TRACEDATA[3] Output Trace data pin 3 - Connected to TRACE0 of 

MB9BF516R 

7,11,13, NC   

3,5,9,15,1

7,19 

GND   

Table 5 - Trace signals and descriptions 

USB Connector (USB1:USB-Device) 

Pin # Signal name Signal type Deccription 

1 VBUS Input Connected to P60-pin of MB9BF516R 

2 USB1_N Input/Output USB Data- 

3 USB1_P Input/Output USB Data+ 

4 NC   

5 GND  GND 

6 SHIELD   

Table 6 - USB signals 

USB Connector (USB2：USB-HOST) 

Pin # Singnal name Signal type Description 

1 VBUS Output USB +5V 

2 USB2_N Input/Output USB Data- 

3 USB2_P Input/Output USB Data+ 

4 GND  GND 

5 SHLD1   

6 SHLD2   

Table 7 - USB signals 
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USB Connector for On-board Debugger (USB3) 

Pin # Signal name Signal type Deccription 

1 VBUS Input +5V Input 

2 USB3_N Input/Output USB Data- 

3 USB3_P Input/Output USB Data+ 

4 NC   

5 GND  GND 

6 SHIELD   

Table 8 - USB signals for On-board debugger 

MCU External pin 1 （J1：Pin header） 

Pin # Signal name Pin # Signal name 

1 MCUVCC 31 MCUVCC 

2 P50 32 P40 

3 P51 33 P41 

4 nUFLG 34 P42 

5 P53 35 P43 

6 P54 36 P44 

7 P55 37 P45 

8 P56 38 NC 

9 P57 39 NC 

10 P58 40 NC 

11 P59 41 NC 

12 P5A 42 NC 

13 P5B 43 nRES 

14 P30 44 P48 

15 P31 45 P49 

16 P32 46 P4A 

17 P33 47 P4B 

18 P34 48 P4C 

19 P35 49 P4D 

20 P36 50 P4E 

21 P37 51 P70 

22 P38 52 P71 

23 P39 53 P72 

24 P3A 54 P73 

25 P3B 55 P74 

26 P3C 56 MD1 

27 P3D 57 MD0 

28 P3E 58 NC 

29 P3F 59 NC 

30 GND 60 GND 

Table 9 - Signal description 
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MCU External Pin 2 （J2：Pin header） 

Pin # Signal name Pin # Signal name 

61 MCUVCC 91 MCUVCC 

62 P10 92 TRST 

63 P11 93 TCK 

64 P12 94 TDI 

65 P13 95 TMS 

66 P14 96 TDO 

67 P15 97 TRACE0 

68 P16 98 TRACE1 

69 P17 99 TRACE2 

70 AVCC 100 TRACE3 

71 AVRH 101 TRACECLK 

72 AGND 102 P0A 

73 P18 103 P0B 

74 P19 104 P0C 

75 P1A 105 P0D 

76 P1B 106 P0E 

77 P1C 107 P0F 

78 P1D 108 P68 

79 P1E 109 P67 

80 P1F 110 P66 

81 P28 111 P65 

82 P27 112 P64 

83 P26 113 P63 

84 P25 114 nUBPON 

85 P24 115 P61 

86 P23 116 P60 

87 P22 117 USBVCC0 

88 P21 118 UDM0 

89 P20 119 UDP0 

90 GND 120 GND 

Table 10 - Signal description 

Power jack (J3) 

There is a standard 2.1 mm power jack mounted on the board. The power input 

should be DC +5V.  

Pin # Signal name Description 

1 Power input +5V 

2 GND GND 

Table 11 - Power jack signals and descriptions 
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Creating a new application 

You can create new application as following procedures without an example application. 

1 Select Project > Create new project 

 

Figure 6 - Create a new project 

 

2 Click on the + mark on the left side of C in the project template 

 

Figure 7 - Select Create a C project 
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3 Select main and click OK. 

 

Figure 8 - Create a C project 

Designate a folder where this project is stored and click Save. In this example a project named 

NewProject is created.  

 

Figure 9 - save your new project 
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4 The new project has been created. 

 

Figure 10 - The new project have been created 

 

5 Edit the main program 

 
Figure 11 - Edit the main program 
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6 Select File > Save Workspace 

 

Figure 12 - Save Workspace 

 

7 The Save Workspace As… screen is shown. Enter the name of your project, in our case 

NewProject, which name is same as the name of the project. Click Save. 

 

Figure 13 - Save Workspace As... 
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8 Click Project  > Option to select the correct options for your project 

 
Figure 14 - Setting the project options 

 

9 Select a device in General Option and the Target tab, click    

 

Figure 15 - Select a device 
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10 Select Fujitsu MB9BF516R 

 

Figure 16 - Select your device 

11 Confirm that Fujitsu MB9BF516R is selected. 

 

Figure 17 - Confirm your device 
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12 Select and set the linker configuration file (.icf file). Change to Category: Linker. 

13 If you select the default .icf file for your device, open the Config tab and check the Override 

default option. 

 

Figure 18 - Confirm your device 

14 If you select your original setting, make a copy of the template linker command file from \IAR 

Systems\Embedded Workbench 6.x Kickstart\arm\config\generic_cortex.icf to 

your stored folder and rename it as MB9BF516R.icf. 

Or, make a copy of the template linker command file from \IAR Systems\Embedded 

Workbench 6.x Kickstart\arm\config\linker\Fujitsu\mb9bf516r.icf to your stored 

folder and rename it as MB9BF516R.icf. 

15 Change to Category: Linker, open the Config tab and check the Override default option. 

 

Figure 19 - Setting the Linger configuration file 
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16 Write $PROJ_DIR$ in the override default text box, and click . $PROJ_DIR$ mean that it is 

found in the project folder. 

 

Figure 20 - Use the linker in the project folder 

 

17 Select MB9BF516R.icf which you earlier created and click Open. 

 

Figure 21 - Select the linker file in your project folder 
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18 Click Edit to edit the linker configuration. 

 

Figure 22 - Edit the linker file 
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19 The Linker configuration file editor is shown and you should enter the following:  

 

Figure 23 - Setting the Vector Table 

 

Figure 24 - Setting the ROM/RAM address 

 

Figure 25 - Setting the Stack/Heap sizes 

After you are done with the linker configuration file editor, click on Save. 
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20 It is now time to build the project by clicking on the Build button. 

 

Figure 26 - Build your project 

21 After correcting possible errors in your code it is time to define your debugger as J-Link. Open 

Project > Option> Category:  Debugger, open the Setup tab and change the driver to J-Link/J-

Trace. 

 

Figure 27 - Setting the debugger option 
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22 Open the Download tab and check Verify download (red circle), then check the Use flash 

loader(s) (blue circle), because this example uses flash area.  

 

Figure 28 - Debugger download settings 

23 Open Category: J-Link/J-Trace and the Connection tab. Select SWD in the Interface option. 

 

Figure 29 - Setting the debug interface 
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24 Open the Setup tab and set the SWD speed. Click OK. 

 

Figure 30 - Setting the debug speed 

25 The project options have now been set and you can start C-SPY and debug your program. 

 

Figure 31 - Start debugging 
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Disclaimer 

Information given in this document is intended as a help for the user. IAR Systems shall not be 

held liable for any losses or problems arising from using the information given in this document. 

Neither whole nor any part of the information in this document may be adapted or reproduced. 

IAR KickStart Kit content Trademarks etc. 

 Installation  DVD   

 IAR MB9BF516R-SK evaluation board   

 USB cable 

 

IAR Systems, IAR Embedded Workbench, C-SPY, IAR 

visualSTATE, The code to Success, IAR Kickstart Kit, 

IAR and the IAR Systems logotype are trademarks or 

registered trademarks owned by IAR Systems AB. 

 

All other trademarks or registered trademarks mentioned 

in this document are the properties of their respective 

owners. 

© Copyright 2012 IAR Systems AB. 

 

Part number: GS-MB9BF516R-2  

Second edition: August 2012. 

Troubleshooting 

If you are unable to find the cause of a problem, try resetting the evaluation board by using the 

reset button on the board. Then restart the C-SPY Debugger in the IAR Embedded Workbench 

IDE. You can also try disconnecting and reconnecting the power to the evaluation board, pressing 

the reset button and then restarting C-SPY. 


